0 / 0
Troubleshooting watsonx.governance
Last updated: Feb 10, 2025
Troubleshooting watsonx.governance

Use these solutions to work around problems with watsonx.governance.

Errors viewing factsheet information for watsonx.governance provisioned in the Sydney data center

If you are using a watsonx.governance service provisioned from the Sydney region, an additional level of access control is required to track assets in an AI use case. Users with admin access to projects and spaces must explicitly authorize access to the metadata for assets in the workspace. If there is an access problem, you will see this error when trying to view a factsheet for a restricted asset: Unable to load the factsheet because the asset has no access to the metadata. Ask an admin for assistance.

The admin for a project or space can grant access as follows:

  1. Click the Manage tab for the project or space.
  2. On the General tab, Click Grant access for the control labeled Reporting on asset metadata is allowed.

Error tracking a model to a Governance console use case when required field is missing

The problem: You try to track a model to a Governance console console use case and you get this error:

Model tracking error: Error creating model on OpenPages. Please contact IBM.

This error can indicate that a custom field in the Governance console use case is marked as Required.

Resolution: Uncheck the Required options for custom fields in the OpenPages use case and try the tracking operation again.

AI Factsheet prompt template for a custom model or tuned model fails to show information

If the factsheet for a prompt template asset created using a custom model or a tuned model fails to display the associated information, check for these issues:

  • If the prompt template asset for a custom model or tuned model was exported from a space, check that the associated model was also exported, as dependencies are not exported by default. Tracking information is not available unless both the prompt template asset and the associated model are available.

Failure to provide a value in a required field results in error

If a custom field in an AI use case that is synced with Governance console is missing, you will see a model-tracking error similar to this:

Model tracking error Failed when executing PUT <URL to OpenPages form>

To resolve the problem, enter a value in the required field and try the sync again.

Removal of the Test lifecycle phase of an AI use case

If you created AI use cases in a previous version of Cloud Pak for Data, factsheet data that was listed in the Test phase is now listed in the Development phase.

OpenPages model use cases and some external assets owned by System in model inventory

Symptoms

When the AI Factsheets service is integrated with IBM OpenPages, the model use cases that sync with the model inventory are owned by System because they are created by the Factsheets service. Existing model assets created from OpenScale evaluation facts are also owned by System. New external model assets created with OpenScale evaluation facts provide the option to assign them to an asset owner.

Causes

You might see the owner of assets as System instead of a username.

Resolving the problem

If you have Administrator access to a catalog, follow these steps to assign a user as owner:

  1. Open the asset in the catalog and select the Assets tab.
  2. Add the user (who has access to the catalog) who will be assigned ownership as a collaborator.
  3. Click the Edit icon for Asset owner in the About this asset section.
  4. Select the username to assign as owner.

Learn more

For issues with Watson OpenScale, see Troubleshooting Watson OpenScale.