0 / 0
Volver a la versión inglesa de la documentación
Inicio rápido: Virtualizar datos

Inicio rápido: Virtualizar datos

Puede utilizar Data Virtualization para crear una tabla virtual para segmentar o combinar datos de una o varias tablas. Data Virtualization conecta varios orígenes de datos en una única colección de equilibrio automático de orígenes de datos o bases de datos. Consulte la herramienta Data Virtualization y, a continuación, vea un vídeo y realice una guía de aprendizaje que sea adecuada para los usuarios con algún conocimiento de la virtualización de datos, pero que no requiera codificación.

Servicio necesario
Data Virtualization
Servicios opcionales
Watson Studio
IBM Knowledge Catalog

El flujo de trabajo básico incluye estas tareas:

  1. Suministre el servicio y cree sus credenciales de servicio.
  2. Cree bases de datos en varios orígenes de datos y recopile las credenciales y los detalles de la base de datos.
  3. Añada conexiones a sus orígenes de datos.
  4. Cree objetos virtuales combinando datos de todos los orígenes de datos.
  5. Gestione el acceso a los objetos virtuales.
  6. Añada datos virtualizados a sus catálogos y proyectos.
  7. Supervise la instancia de servicio con la consola de gestión de datos de IBM Db2.

Información sobre Data Virtualization

Con el servicio de Data Virtualization, puede conectarse a varios orígenes de datos, crear y gobernar activos virtuales y consumir los datos virtualizados.

Más información sobre Data Virtualization

Ver un vídeo sobre Data Virtualization

Ver vídeo Vea este vídeo para ver cómo virtualizar datos en un proyecto o catálogo utilizando el servicio Data Virtualization .

Este vídeo proporciona un método visual para aprender los conceptos y tareas de esta documentación.


Pruebe una guía de aprendizaje para virtualizar datos

En esta guía de aprendizaje, realizará estas tareas:

Le llevará aproximadamente 30 minutos el completar esta guía de aprendizaje.





Sugerencias para completar esta guía de aprendizajeEstas son algunas sugerencias para completar correctamente esta guía de aprendizaje.

Utilizar la imagen en imagen de vídeo

Sugerencia: Inicie el vídeo y, a continuación, a medida que se desplaza por el tutorial, el vídeo se desplaza al modo de imagen en imagen. Cierre la tabla de contenido de vídeo para obtener la mejor experiencia con la imagen en imagen. Puede utilizar el modo de imagen en imagen para poder seguir el vídeo mientras completa las tareas de este tutorial. Pulse las indicaciones de fecha y hora para cada tarea a seguir.

La siguiente imagen animada muestra cómo utilizar las características de imagen en imagen y tabla de contenido de vídeo:

Cómo utilizar la imagen en la imagen y los capítulos

Obtener ayuda en la comunidad

Si necesita ayuda con esta guía de aprendizaje, puede formular una pregunta o encontrar una respuesta en el foro de discusión de la comunidad deCloud Pak for Data.

Configurar las ventanas del navegador

Para obtener la experiencia óptima al completar esta guía de aprendizaje, abra Cloud Pak for Data en una ventana de navegador y mantenga abierta esta página de la guía de aprendizaje en otra ventana de navegador para conmutar fácilmente entre las dos aplicaciones. Considere la posibilidad de organizar las dos ventanas del navegador una al lado de la otra para que sea más fácil de seguir.

Guía de aprendizaje en paralelo e interfaz de usuario

Sugerencia: Si encuentra una visita guiada al completar esta guía de aprendizaje en la interfaz de usuario, pulse Quizás más tarde.



Tarea 1: Abrir un proyecto

vídeo tutorial de vista previa Para obtener una vista previa de esta tarea, vea el vídeo que empieza en 00:10.

Necesita un proyecto para almacenar los datos virtualizados. Siga estos pasos para abrir un proyecto existente o crear un proyecto nuevo.

  1. En el Cloud Pak for Data menú de navegación Menú de navegación, elija Proyectos > Ver todos los proyectos

  2. Si tiene un proyecto existente, ábralo.

  3. Si no tiene un proyecto existente, pulse Nuevo proyecto.

  4. Seleccione Crear un proyecto vacío.

  5. Especifique un nombre y una descripción opcional para el proyecto.

  6. Elija una instancia de servicio de almacenamiento de objetos existente o cree una nueva.

  7. Pulse Crear.

Para obtener más información o ver un vídeo, consulte Creación de un proyecto.

Icono de punto de comprobación Compruebe el progreso

La imagen siguiente muestra un proyecto nuevo vacío.

La imagen siguiente muestra un proyecto nuevo vacío.




Tarea 2: Suministrar los servicios necesarios

vídeo tutorial de vista previa Para obtener una vista previa de esta tarea, vea el vídeo que empieza en 00:32.

Esta guía de aprendizaje requiere el servicio Data Virtualization y servicios opcionales Watson Studio e IBM Knowledge Catalog. Siga estos pasos para crear estos servicios:

  1. En el Menú de navegación Menú de navegación, pulse Servicios > Instancias de servicio.

  2. Si tiene un servicio Data Virtualization listado, no es necesario que suministre otra instancia. De lo contrario, siga estos pasos:

    1. Pulse Añadir servicio.

    2. Seleccione Data Virtualization.

    3. Seleccione el plan Lite para Data Virtualization.

    4. Pulse Crear.

  3. Verifique que los servicios se suministran en la página Instancias de servicio.

Para obtener más información, consulte Data Virtualization en Cloud Pak for Data as a Service.

Icono de punto de comprobación Compruebe el progreso

La imagen siguiente muestra los servicios suministrados.

La imagen siguiente muestra los servicios suministrados.




Tarea 3: Añadir una conexión al origen de datos Db2 Warehouse

vídeo tutorial de vista previa Para obtener una vista previa de esta tarea, vea el vídeo que empieza en 00:58.

Para poder virtualizar los datos, debe crear una conexión con el origen de datos. Siga estos pasos para crear una conexión en Data Virtualization:

  1. En el Menú de navegación Menú de navegación, seleccione Datos > Data virtualization. Se visualiza la lista de Orígenes de datos configurados.

  2. Pulse Añadir conexión > Nueva conexión.

  3. Seleccione Db2 Warehouse on Cloudy pulse Seleccionar.

  4. Complete los detalles de conexión utilizando la información siguiente:

    • Nombre: Db2 Warehouse
    • Base de datos: BLUDB
    • Nombre de host o dirección IP: db2w-ruggyab.us-south.db2w.cloud.ibm.com
    • Puerto: 50001
    • Nombre de usuario: CPDEMO
    • Contraseña: DataFabric@2022IBM
    • Seleccione el recuadro de selección El puerto está habilitado para SSL .
  5. Pulse Probar.

  6. Pulse Crear.

Para obtener más información, consulte Adición y conexión a orígenes de datos en Data Virtualization.

Icono de punto de comprobación Compruebe el progreso

La imagen siguiente muestra la página Orígenes de datos.

La imagen siguiente muestra la página Orígenes de datos.




Tarea 4: Añadir tablas a los datos virtualizados

vídeo tutorial de vista previa Para obtener una vista previa de esta tarea, vea el vídeo que empieza en 01:45.

Con la conexión definida, puede virtualizar los datos de ese origen de datos. Siga estos pasos para añadir las tablas a los datos virtualizados.

  1. En el menú Data Virtualization , seleccione Virtualización > Virtualizary espere a que se carguen las tablas disponibles.

  2. Localice y seleccione las tablas clientes y ventas de la lista y pulse Añadir al carro.

  3. Pulse Ver carro.

  4. Borre el campo Asignar a proyecto . Esto añadirá las dos tablas a la lista de datos virtualizados, pero no las añadirá a un proyecto. Más adelante, añadirá datos virtualizados al proyecto.

  5. Pulse Virtualizar.

  6. Pulse Confirmar.

  7. Pulse Ir a datos virtualizados.

Para obtener más información, consulte Creación de objetos virtuales en Data Virtualization.

Icono de punto de comprobación Compruebe el progreso

La imagen siguiente muestra la página Mis datos virtualizados.

La imagen siguiente muestra la página Mis datos virtualizados.




Tarea 5: Publicar datos virtualizados en un catálogo y proyecto

vídeo tutorial de vista previa Para obtener una vista preliminar de esta tarea, vea el vídeo que empieza en 02:43.

A continuación, siga estos pasos para unir dos tablas para crear un activo virtualizado y publicarlo en un catálogo y proyecto:

  1. En la pantalla Datos virtualizados, seleccione las tablas clientes y ventas de la lista y pulse Unir.

  2. Para cada tabla, busque salesrep.

  3. Conecte las columnas SALESREP_ID de las dos tablas.

  4. Pulse Siguiente.

  5. Revise la tabla unida y pulse Siguiente.

  6. Para el nombre de la vista, escriba joined_customers_sales_table.

  7. Seleccione un servidor en la lista.

  8. Marque la opción Publicar en catálogo y seleccione un catálogo.

  9. Pulse Crear vista.

  10. Cuando se completa el proceso, puede ver el proyecto o el catálogo para obtener una vista previa de los datos virtualizados. Necesitará una clave de API de IBM Cloud para ver los datos del proyecto o catálogo. Consulte Creación de una clave de API de IBM Cloud.

Para obtener más información, consulte Gobierno de datos virtuales en Data Virtualization.

Icono de punto de comprobación Compruebe el progreso

La imagen siguiente muestra el activo de datos virtualizados en el catálogo.

La imagen siguiente muestra el activo de datos virtualizados en el catálogo.



Próximos pasos

Ahora sus datos virtuales están listos para ser utilizados. Por ejemplo, puede realizar cualquiera de estas tareas:

Recursos adicionales

Tema principal: Guías de aprendizaje de inicio rápido

Búsqueda y respuesta de IA generativa
Estas respuestas las genera un modelo de lenguaje grande en watsonx.ai que se basa en el contenido de la documentación del producto. Más información