Démarrage rapide : Analyse des données dans un bloc-notes Jupyter

Vous pouvez créer un bloc-notes dans lequel vous exécutez le code pour préparer, visualiser et analyser des données, ou générer et entraîner un modèle. Lisez en plus sur les clocs-notes Jupyter, puis regardez une vidéo et suivez un tutoriel qui convient aux utilisateurs ayant une certaine connaissance du code Python.

Votre flux de travaux de base inclut les tâches suivantes :

  1. Créez un projet. Les projets sont l'endroit où vous collaborez avec d'autres personnes sur les données.
  2. Ajoutez vos données au projet. Vous pouvez ajouter des fichiers CSV ou des données à partir d'une source de données distante via une connexion.
  3. Créez un bloc-notes dans le projet.
  4. Ajoutez du code au bloc-notes pour charger et analyser vos données.
  5. Exécutez votre bloc-notes et partagez les résultats avec vos collègues.

En savoir plus sur les blocs-notes

Un bloc-notes Jupyter est un environnement basé sur le Web pour un calcul interactif. Vous pouvez exécuter de petites portions de code qui traitent vos données et visualiser immédiatement les résultats de votre calcul. Les blocs-notes incluent tous les blocs de construction dont avez besoin pour gérer des données :

  • Les données
  • Les calculs de code qui traitent les données
  • Les visualisations des résultats
  • Du texte et des médias riches pour une meilleure compréhension

En savoir plus sur les blocs-notes

Regarder une vidéo sur les blocs-notes

Regardez une vidéo Regardez cette vidéo pour apprendre les bases des blocs-notes Jupyter.

Cette vidéo constitue une alternative visuelle aux procédures figurant dans cette documentation.

Essayer un tutoriel pour créer un bloc-notes

Dans ce tutoriel, vous :

  • Créer un projet et ajouter un actif à partir de la galerie.
  • Créer un bloc-notes.
  • Analyser des données dans le bloc-notes.
  • Editer et partager le bloc-notes.
  • Créer un travail pour exécuter le bloc-notes.

Ce tutoriel prendra environ 15 minutes pour se réaliser.

Etape 1 : Création d'un projet et ajout d'un actif à partir de la galerie

{: #step1} Vous avez besoin d'un projet pour stocker le bloc-notes et l'actif de données.

  1. Si vous avez un projet existant, ouvrez-le. Si vous ne disposez pas d'un projet existant, cliquez sur Créer un projet sur la page d'accueil ou sur Nouveau projet sur votre page Projets.
  2. Sélectionnez Créer un projet vide.
  3. Dans l'écran Créer un projet , ajoutez un nom et une description facultative pour le projet.
  4. Choisissez une instance de service de stockage d'objets existante ou créez-en une nouvelle.
  5. Cliquez sur Créer.
  6. Dans le menu de navigation, cliquez sur Galerie.
  7. Recherchez un ensemble de données intéressant, puis sélectionnez le fichier.
  8. Cliquez sur Ajouter au projet.
  9. Sélectionnez le projet dans la liste et cliquez sur Ajouter.
  10. Une fois le fichier ajouté, cliquez sur Afficher le projet. Le fichier se trouve dans l'onglet Actifs.

Pour plus d'informations ou pour regarder une vidéo, voir Création d'un projet.
Pour plus d'informations sur l'ajout d'actifs de la Galerie à un projet d'accès dans un bloc-notes, voir Chargement et accès aux données dans un bloc-notes.

Etape 2 : Ajout d'un bloc-notes à votre projet

{: #step2} Créez un bloc-notes dans votre projet.

  1. Dans la page Actifs de votre projet, cliquez sur Nouvel actif > Bloc-notes.
  2. Entrez un nom et une description (facultatif).
  3. Sélectionnez un environnement d'exécution pour ce bloc-notes.
  4. Cliquez sur Créer. Attendez que l'éditeur de bloc-notes se charge.

Etape 3 : Chargement d'un fichier et enregistrement du bloc-notes

{: #step3} Chargez les données dans un cadre de données de pandas.

  1. Cliquez sur l'icône Rechercher et ajouter des données.
  2. Dans l'onglet Fichiers, cliquez sur la liste déroulante Insérer dans le code à coté du fichier que vous avez ajouté, puis insérez le fichier pandas DataFrame.
  3. Cliquez sur Exécuter pour exécuter votre code. Les premières lignes de votre ensemble de données s'affichent.
  4. Pour sauvegarder une version de votre bloc-notes, cliquez sur Fichier > Enregistrer la version. Vous pouvez également sauvegarder votre bloc-notes avec Fichier > Enregistrer.

Etape 4 : Recherche et édition du bloc-notes

{: #step4} Recherchez le bloc-notes sauvegardé dans l'onglet Actifs et éditez le bloc-notes.

  1. Revenez à votre projet pour trouver votre bloc-notes dans l'onglet Actifs.
  2. Lorsque vous cliquez sur le bloc-notes, il s'ouvre en mode READ ONLY.
  3. Pour modifier le bloc-notes, cliquez sur l'icône Crayon.
  4. Accédez au panneau Infos.
  5. Dans l'onglet Général, modifiez le nom et la description du bloc-notes.
  6. Cliquez sur l'onglet Environnement pour voir où vous pouvez modifier l'environnement utilisé pour exécuter le bloc-notes ou mettre à jour le statut d'exécution pour arrêter et redémarrer.

Etape 5 : Partage de la version en lecture seule du bloc-notes

{: #step5} Créez un lien vers le bloc-notes à partager avec vos collègues.

  1. Cliquez sur l'icône Partager si vous souhaitez partager la vue en lecture seule du bloc-notes.
  2. Cliquez pour activer le bouton à bascule Partager avec toute personne ayant le lien.
  3. Sélectionnez le contenu que vous souhaitez partager via un lien ou un réseau social.
  4. Cliquez sur Close.

Etape 6 : Planification de l'exécution d'un bloc-notes à un autre moment

{: #step6} Créez un travail pour planifier l'exécution du bloc-notes à une heure ou une répétition spécifique en fonction d'un planning.

  1. Cliquez sur l'icône Travail et sélectionnez Créer un travail.
  2. Indiquez le nom et la description du travail, puis cliquez sur Suivant.
  3. Sélectionnez la version du bloc-notes et l'environnement d'exécution de l'environnement, puis cliquez sur Suivant.
  4. (Facultatif) Cliquez sur le bouton à bascule pour planifier une exécution. Indiquez la date, l'heure et si vous souhaitez que le travail se répète, puis cliquez sur Suivant.
  5. (Facultatif) Cliquez sur le bouton à bascule pour recevoir des notifications pour ce travail, puis cliquez sur Suivant.
  6. Consultez les détails et cliquez sur Créer (pour créer le travail, mais pas sur l'exécution immédiate du travail) ou sur Créer et exécuter (pour exécuter le travail immédiatement).
  7. Le travail s'affiche dans l'onglet Travaux du projet.

Etapes suivantes

A présent, vous pouvez utiliser ce fichier pour une analyse plus approfondie. Par exemple, vous ou d'autres utilisateurs pouvez effectuer l'une des tâches suivantes :

Autres ressources

  • Afficher plus de vidéos pour les blocs-notes.
  • Trouvez des exemples d'ensembles de données et de blocs-notes pour acquérir une expérience pratique de l'affinage des données dans la galerie.
  • Accélérez l'utilisation de vos données à l'aide des accélérateurs industriels fournies par IBM, qui constituent un ensemble de solutions de bout en bout que vous pouvez exécuter en tant qu'exemples ou les personnaliser pour traiter des problèmes métier communs. La plupart des accélérateurs incluent un exemple de projet avec tout ce dont vous avez besoin pour analyser les données, construire un modèle et afficher les résultats.

Rubrique parent : Initiation à l'analyse et à la visualisation des données