0 / 0
Zurück zur englischen Version der Dokumentation
Lernprogramm zur Datenintegration: Externe Daten virtualisieren

Lernprogramm zur Datenintegration: Externe Daten virtualisieren

Führen Sie dieses Lernprogramm aus, um Daten, die in drei externen Datenquellen gespeichert sind, mit dem Data Integration-Anwendungsfall der Data-Fabric-Testversion zu virtualisieren. Ihr Ziel ist es, Data Virtualization zu verwenden, um virtuelle Tabellen zu erstellen und die virtuellen Tabellen aus den vorhandenen Daten zu verknüpfen, die sich in drei Datenquellen befinden: Db2 Warehouse, eine PostgreSQL -Datenbank und eine MongoDB -Datenbank. Wenn Sie das Lernprogramm Daten integrieren abgeschlossen haben, haben Sie viele derselben Tasks mithilfe von DataStage ausgeführt, die dieses Lernprogramm mithilfe von Data Virtualizationausführt.

Schnelleinstieg: Wenn das Beispielprojekt für dieses Lernprogramm noch nicht erstellt wurde, greifen Sie auf das Beispielprojekt für die Datenintegration im Ressourcenhub zu.

In diesem Lernprogramm muss die Golden Bank eine neue Verordnung einhalten, in der sie keine Kredite an unterqualifizierte Darlehensantragsteller vergeben kann. Sie werden Data Virtualization verwenden, um Daten aus verschiedenen Datenquellen ohne Versetzen von Daten zu kombinieren und die virtuellen Daten anderen Data-Scientists und Datenentwicklern in einem Projekt zur Verfügung zu stellen.

Das folgende animierte Bild bietet eine kurze Vorschau dessen, was Sie am Ende dieses Lernprogramms erreichen werden. Sie stellen eine Verbindung zu externen Datenquellen her, erstellen virtuelle Tabellen und Ansichten und fügen sie einem Projekt hinzu. Klicken Sie auf das Bild, um ein größeres Bild anzuzeigen.

Animiertes Bild

Vorschau des Lernprogramms anzeigen

In diesem Lernprogramm werden Sie die folgenden Tasks ausführen:

Video ansehen Sehen Sie sich dieses Video an, um eine Vorschau der Schritte in diesem Lernprogramm anzuzeigen. Möglicherweise gibt es geringfügige Unterschiede in der Benutzerschnittstelle, die im Video angezeigt wird. Das Video ist als Begleiter zum schriftlichen Lernprogramm gedacht.

Dieses Video bietet eine visuelle Methode zum Erlernen der Konzepte und Tasks in dieser Dokumentation.





Tipps zum Durcharbeiten dieses LernprogrammsIm Folgenden finden Sie einige Tipps für den erfolgreichen Abschluss dieses Lernprogramms.

Verwenden Sie das Videobild im Bild

Tipp: Starten Sie das Video. Wenn Sie dann durch das Lernprogramm blättern, wechselt das Video in den Bildmodus. Schließen Sie das Video-Inhaltsverzeichnis für die beste Erfahrung mit Bild-in-Bild. Sie können den Modus "Bild im Bild" verwenden, damit Sie dem Video folgen können, während Sie die Tasks in diesem Lernprogramm ausführen. Klicken Sie auf die Zeitmarken für jede zu befolgende Task.

Die folgende animierte Abbildung zeigt, wie die Funktionen für Videobilder und Inhaltsverzeichnisse verwendet werden:

Verwendung von Bildern und Kapiteln

Hilfe in der Community anfordern

Wenn Sie Hilfe bei diesem Lernprogramm benötigen, können Sie eine Frage stellen oder eine Antwort im Diskussionsforum derCloud Pak for Data Communityfinden.

Browserfenster einrichten

Damit Sie dieses Lernprogramm optimal nutzen können, öffnen Sie Cloud Pak for Data in einem Browserfenster und lassen Sie diese Lernprogrammseite in einem anderen Browserfenster geöffnet, um einfach zwischen den beiden Anwendungen zu wechseln. Es empfiehlt sich, die beiden Browserfenster nebeneinander anzuordnen, um die weitere Arbeit zu erleichtern.

Paralleles Lernprogramm und Benutzerschnittstelle

Tipp: Wenn Sie beim Durcharbeiten dieses Lernprogramms in der Benutzerschnittstelle auf eine geführte Tour stoßen, klicken Sie auf Vielleicht später.



Voraussetzungen einrichten

Für Cloud Pak for Data as a Service anmelden

Sie müssen sich für Cloud Pak for Data as a Service registrieren und die erforderlichen Services für den Anwendungsfall der Datenintegration bereitstellen.

  • Wenn Sie über ein Cloud Pak for Data as a Service -Konto verfügen, können Sie mit diesem Lernprogramm beginnen. Wenn Sie über ein Lite-Plankonto verfügen, kann nur ein Benutzer pro Konto dieses Lernprogramm ausführen.
  • Wenn Sie noch kein Konto für Cloud Pak for Data as a Service haben, melden Sie sich für einen Data-Fabric-Test an.

Symbol 'Video' Sehen Sie sich das folgende Video an, um mehr über das Datenfabric in Cloud Pak for Data.

Dieses Video bietet eine visuelle Methode zum Erlernen der Konzepte und Tasks in dieser Dokumentation.

Erforderliche bereitgestellte Services überprüfen

Vorschau-Lernprogrammvideo Sehen Sie sich das Video ab 01:06an, um eine Vorschau dieser Task anzuzeigen.

Führen Sie die folgenden Schritte aus, um die erforderlichen Services zu überprüfen oder bereitzustellen:

  1. Wählen Sie im Navigationsmenü Cloud Pak for Data Navigationsmenüdie Optionen Services > Serviceinstanzen.

  2. Verwenden Sie die Dropdown-Liste Produkt , um festzustellen, ob eine vorhandene Data Virtualization -Serviceinstanz vorhanden ist.

  3. Wenn Sie eine Data Virtualization -Serviceinstanz erstellen müssen, klicken Sie auf Service hinzufügen.

    1. Wählen Sie Data Virtualization aus.

    2. Wählen Sie den Plan Lite aus.

    3. Klicken Sie auf Erstellen.

  4. Warten Sie, bis der Service Data Virtualization bereitgestellt ist. Dies kann einige Minuten dauern.

  5. Wiederholen Sie diese Schritte, um die folgenden zusätzlichen Services zu überprüfen oder bereitzustellen:

    • IBM Knowledge Catalog
    • Cloud Object Storage

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die bereitgestellten Serviceinstanzen:

Bereitgestellte Services

Beispielprojekt erstellen

Vorschau-Lernprogrammvideo Um eine Vorschau dieser Task anzuzeigen, sehen Sie sich das Video ab 01:46an.

Wenn Sie bereits über das Beispielprojekt für dieses Lernprogramm verfügen, fahren Sie mit Aufgabe 1fort. Andernfalls führen Sie die folgenden Schritte aus:

  1. Greifen Sie auf das Beispielprojekt für die Datenintegration im Ressourcenhub zu.

  2. Klicken Sie auf Projekt erstellen.

  3. Wenn Sie aufgefordert werden, das Projekt einer Cloud Object Storage-Instanz zuzuordnen, wählen Sie in der Liste eine Cloud Object Storage-Instanz aus.

  4. Klicken Sie auf Erstellen.

  5. Warten Sie, bis der Projektimport abgeschlossen ist, und klicken Sie auf Neues Projekt anzeigen , um zu überprüfen, ob das Projekt und die Assets erfolgreich erstellt wurden.

  6. Klicken Sie auf die Registerkarte Assets , um die Verbindungen und den DataStage -Ablauf anzuzeigen.

Hinweis: Sie sehen möglicherweise eine geführte Tour mit den Lernprogrammen, die in diesem Anwendungsfall enthalten sind. Die Links in der geführten Tour öffnen diese Lernprogrammanweisungen.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die Registerkarte 'Assets' im Beispielprojekt. Sie können jetzt das Lernprogramm starten.

Beispielprojekt




Aufgabe 1: Platform assets catalog überprüfen

Vorschau-Lernprogrammvideo Um eine Vorschau dieser Task anzuzeigen, sehen Sie sich das Video ab 02:42an.

Sie können Verbindungen zu externen Datenquellen auf Plattformebene oder auf Serviceebene hinzufügen. Wenn Sie die Verbindungen auf Plattformebene mithilfe des Platform assets cataloghinzufügen, können Sie diese Verbindungen ohne großen Aufwand in Projekte, Kataloge und Data Virtualization -Datenquellen einbeziehen. Führen Sie die folgenden Schritte aus, um den Platform assets catalogzu überprüfen.

  1. Wählen Sie im Navigationsmenü Cloud Pak for Data Navigationsmenü Daten > Plattformverbindungenaus.

  2. Wenn Sie vorhandene Verbindungen sehen, haben Sie bereits einen Platform assets catalogund können mit Aufgabe 2fortfahren. Wenn keine Verbindungen angezeigt werden, aber eine Option zum Erstellen einer neuen Verbindung angezeigt wird, können Sie mit Task 2fortfahren.
    Schaltfläche für neue Verbindung

  3. Wenn Sie keinen Platform assets cataloghaben, klicken Sie auf Katalog erstellen. Plattformassetkatalog erstellen

  4. Wählen Sie Cloud Object Storage in der Liste aus.

  5. Akzeptieren Sie den Standardwert für Handhabung doppelter Anlagen.

  6. Klicken Sie auf Erstellen. Die Seite Plattformverbindungen wird angezeigt.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die Plattformverbindungen. Von hier aus können Sie Verbindungen erstellen. Da das Beispielprojekt die Verbindungen enthält, können Sie die Verbindungen für die externen Datenquellen diesem Katalog aus dem Beispielprojekt hinzufügen.

Platform assets catalog




Aufgabe 2: Datenverbindungen zum Platform assets catalog

Vorschau-Lernprogrammvideo Um eine Vorschau dieser Task anzuzeigen, sehen Sie sich das Video ab 03:22an.

Das Beispielprojekt für die Datenintegration enthält mehrere Verbindungen zu externen Datenquellen. Anschließend fügen Sie drei Verbindungen zum Platform assets cataloghinzu und können diese Verbindungen dann in Data Virtualizationverfügbar machen. Führen Sie die folgenden Schritte aus, um die Verbindungen aus dem Beispielprojekt im Platform assets catalogzu veröffentlichen.

  1. Wählen Sie im Navigationsmenü Cloud Pak for Data Navigationsmenü Projekte > Alle Projekte anzeigenaus.

  2. Klicken Sie auf das Projekt Datenintegration .

  3. Klicken Sie auf die Registerkarte Assets.

  4. Klicken Sie unter Assettypenauf Datenzugriff > Verbindungen.

  5. Wählen Sie die folgenden Verbindungsassets aus:

    • Data Fabric -Testversion- Db2 Warehouse
    • Testversion vonData Fabric - MongoDB
    • Data Fabric -Testversion- Databases for PostgreSQL
  6. Klicken Sie auf Im Katalog veröffentlichen.

    1. Wählen Sie in der Liste den Plattformassetkatalog aus und klicken Sie auf Weiter.

    2. Prüfen Sie die Assets und klicken Sie auf Veröffentlichen.

  7. Wählen Sie im Navigationsmenü Cloud Pak for Data Navigationsmenüdie Optionen Daten > Plattformverbindungen aus, um die drei Verbindungen anzuzeigen, die im Katalog publiziert werden.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die drei Plattformverbindungen. Sie können jetzt Datenquellen hinzufügen.

Drei Plattformverbindungen




Aufgabe 3: Datenquellen zu Data Virtualization hinzufügen

Vorschau-Lernprogrammvideo Sehen Sie sich das Video ab 04:05an, um eine Vorschau dieser Task anzuzeigen.

Jetzt können Sie diese externen Datenquellen aus dem Platform assets catalog zu Data Virtualizationhinzufügen. Gehen Sie wie folgt vor, um die Datenquellen hinzuzufügen:

  1. Wählen Sie im Navigationsmenü Cloud Pak for Data Navigationsmenüdie Option Daten > Data virtualization.

    Hinweis: Wenn Ihnen eine Benachrichtigung zum Einrichten eines primären Katalogs zur Durchsetzung von Governanceangezeigt wird, können Sie diese Benachrichtigung sicher schließen. Die Einrichtung eines primären Katalogs ist optional.
  2. Klicken Sie auf der Seite Datenquellen in der Tabellensichtauf Verbindung hinzufügen > Vorhandene Plattformverbindung.
    Vorhandene Verbindung hinzufügen

  3. Wählen Sie Data Fabric Trial- Db2 Warehouseaus.

  4. Klicken Sie auf Hinzufügen.

  5. Wiederholen Sie diese Schritte, um die Verbindungen Data Fabric Trial-Mongo DB und Data Fabric Trial- Databases for PostgreSQL hinzuzufügen.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die Datenquellen. Sie können jetzt eine virtuelle Tabelle aus Daten erstellen, die in diesen externen Datenquellen gespeichert sind.

Datenquellen




Task 4: Datentabellen virtualisieren

Vorschau-Lernprogrammvideo Um eine Vorschau dieser Task anzuzeigen, sehen Sie sich das Video ab 04:40an.

Sie möchten die Tabellen MORTGAGE_APPLICATION, MORTGAGE_APPLICANTund CREDIT_SCORES virtualisieren. Später können Sie die ersten beiden virtuellen Tabellen mit der dritten Tabelle verknüpfen, um eine neue virtuelle Joinansicht zu erstellen. Gehen Sie wie folgt vor, um die Datentabellen zu virtualisieren:

  1. Klicken Sie im Servicemenü auf Virtualisierung > Virtualisieren.
    Virtualisierung im Servicemenü

  2. Wechseln Sie bei Bedarf in die Ansicht Tabellen und warten Sie, bis die Tabellen geladen sind. Dies kann bis zu 30 Sekunden dauern. Möglicherweise müssen Sie auf Aktualisieren klicken, um die vollständige Liste der Tabellen anzuzeigen. Wenn Verfügbare Tabellenangezeigt wird, werden alle Tabellen geladen. Die Anzahl der Tabellen kann variieren.
    Liste der verfügbaren Tabellen virtualisieren

  3. Filtern Sie auf der Registerkarte Tabellen die Tabellen anhand der folgenden Kriterien:

    1. Connector: IBM Db2 Warehouse und PostgreSQL

    2. Datenbank: Data Fabric Test- Db2 Warehouse und Data Fabric Test- Databases for PostgreSQL

    3. Schema: BANKING

  4. Wählen Sie die zu virtualisierenden Tabellen MORTGAGE_APPLICATION, MORTGAGE_APPLICANTund CREDIT_SCORE aus. Sie können den Mauszeiger über einen Tabellennamen bewegen, um den vollständigen Namen anzuzeigen und zu überprüfen, ob Sie die richtigen Tabellennamen auswählen.

  5. Klicken Sie auf Zum Warenkorb hinzufügen.

  6. Klicken Sie auf Warenkorb anzeigen , um Ihre Auswahl anzuzeigen. Hier können Sie die Tabellen-und Schemanamen bearbeiten oder eine Auswahl aus Ihrem Warenkorb entfernen.

  7. Wählen Sie zunächst das Kontrollkästchen neben Assign to projectab. Durch diese Aktion werden die virtuellen Tabellen auf der Seite Virtualisierte Daten verfügbar gemacht.

  8. Klicken Sie auf Virtualisieren.

  9. Klicken Sie auf Bestätigen , um mit der Virtualisierung der Tabellen zu beginnen.

  10. Klicken Sie nach Abschluss der Virtualisierung auf Zu virtualisierten Daten wechseln , um die neu erstellte Tabelle anzuzeigen.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die Seite Virtualisierte Daten . Sie können jetzt eine virtuelle Tabelle erstellen, indem Sie diese virtuellen Tabellen verknüpfen.

Virtualisierte Daten




Task 5: Virtuelle Verknüpfungsansichten durch Verknüpfen virtueller Tabellen erstellen

Sie möchten eine virtuelle Joinansicht erstellen, indem Sie die virtuellen Tabellen MORTGAGE_APPLICANT und MORTGAGE_APPLICATION verknüpfen. Anschließend möchten Sie das resultierende virtuelle Objekt mit der virtuellen Tabelle CREDIT_SCORE verknüpfen, um eine zweite virtuelle Joinansicht zu erstellen.

Virtuelle Verknüpfungsansicht 1: An den virtuellen Tabellen MORTGAGE_APPLICANT und MORTGAGE_APPLICATION teilnehmen

Vorschau-Lernprogrammvideo Um eine Vorschau dieser Task anzuzeigen, sehen Sie sich das Video ab 05:59an.

Gehen Sie wie folgt vor, um die erste virtuelle Verknüpfungsansicht zu erstellen:

  1. Wählen Sie auf der Seite Virtualisierte Daten die zu virtualisierenden Tabellen MORTGAGE_APPLICATION und MORTGAGE_APPLICANT aus.

  2. Notieren Sie den Schemanamen. Sie benötigen diesen Namen später, um eine SQL-Abfrage auszuführen.

  3. Klicken Sie auf Join.

  4. Ziehen Sie in der Liste der Spalten für die Tabelle MORTGAGE_APPLICATION , um die Spalte ID mit der Spalte ID in der Tabelle MORTGAGE_APPLICANT zu verbinden.
    Virtuelle Objekte mit ID für Schlüssel verknüpfen

  5. Wählen Sie alle Spalten in beiden Tabellen aus.

  6. Klicken Sie auf Vorschau , um eine Vorschau der verknüpften Tabellen anzuzeigen.

  7. Schließen Sie das Vorschaufenster.

  8. Klicken Sie auf Im SQL-Editor öffnenund anschließend auf Weiter , um zu sehen, dass Sie nicht zum Erstellungsbereich für Joins zurückkehren können. Mit dem SQL-Editor können Sie Abfragen für das Dataset ausführen. In diesem Fall möchten Sie eine Vorschau anzeigen, welche Datensätze das Dataset enthalten soll, wenn Sie nach Bewerbern in Kalifornien filtern.

    SQL-Editor öffnen

    1. Kopieren Sie Ihr Schema und löschen Sie dann die vorhandene Abfrage. Sie müssen Ihr Schema in die nächste SQL-Anweisung einfügen.

    2. Kopieren Sie die folgende Anweisung SELECT für die neue Abfrage und fügen Sie sie ein. Ersetzen Sie <your schema> durch den Schemanamen, den Sie zuvor notiert haben.

      SELECT * FROM <your-schema>.MORTGAGE_APPLICANT WHERE STATE_CODE LIKE 'CA'
      

      Ihre Abfrage ähnelt SELECT * FROM DV_IBMID_663002GN1Q.MORTGAGE_APPLICANT WHERE STATE_CODE LIKE 'CA'
      Anweisung SELECT

    3. Klicken Sie auf Alle ausführen.

    4. Wählen Sie nach Abschluss der Abfrage die Abfrage auf der Registerkarte Verlauf aus. Auf der Registerkarte Ergebnisse sehen Sie, dass die Tabelle nur für Bewerber aus dem Bundesstaat Kalifornien gefiltert wird.

    5. Klicken Sie auf Zurück , um den SQL-Editor zu schließen.

  9. Nachdem Sie nun eine Vorschau des Datasets angezeigt haben, das nach Bewerbern in Kalifornien gefiltert wurde, fügen Sie diese Filterkriterien zur virtuellen Joinansicht hinzu. Kopieren Sie für die Tabelle MORTGAGE_APPLICANT die folgende Anweisung und fügen Sie sie für die Filterkriterien ein: Ersetzen Sie <your schema> durch den Schemanamen, den Sie zuvor notiert haben.

    "<your-schema>"."MORTGAGE_APPLICANT"."STATE_CODE"='CA'
    

    Ihre Filterkriterien ähneln "DV_IBMID_663002GN1Q". "MORTGAGE_APPLICANT". "STATE_CODE" = 'CA'

    Filterkriterien

  10. Klicken Sie auf Weiter.

  11. Sie können die Spaltennamen bearbeiten, um Spalten mit demselben Namen in beiden Tabellen zu unterscheiden. Behalten Sie in diesem Fall die Standardspaltennamen bei und klicken Sie auf Weiter.

  12. Geben Sie auf der Seite Zuweisen und überprüfen für Ansichtsname APPLICANTS_APPLICATIONS_JOINEDein.

  13. Wählen Sie zunächst die Option Zu Projekt zuordnen ab. Später erstellen Sie ein virtuelles Objekt und ordnen dieses dem Datenintegrationsprojekt zu.

  14. Klicken Sie auf Ansicht erstellen.

  15. Klicken Sie nach Abschluss der Virtualisierung auf Zu virtualisierten Daten wechseln , um die neu erstellte Joinansicht anzuzeigen.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die Seite Virtualisierte Daten . Sie können jetzt eine zweite Ansicht für virtuelle Joins erstellen.

Virtualisierte Daten

Virtuelle Verknüpfungsansicht 2: Virtuelle Tabellen APPLICANTS_APPLICATIONS_JOINED und CREDIT_SCORE verknüpfen

Vorschau-Lernprogrammvideo Um eine Vorschau dieser Task anzuzeigen, sehen Sie sich das Video ab 07:47an.

Führen Sie die folgenden Schritte aus, um die zweite Ansicht für virtuelle Joins zu erstellen:

  1. Wählen Sie auf der Seite Virtualisierte Daten die Tabellen APPLICANTS_APPLICATIONS_JOINED und CREDIT_SCORE für die Virtualisierung aus.

  2. Klicken Sie auf Join.

  3. Ziehen Sie in der Liste der Spalten für die Tabelle APPLICANTS_APPLICATIONS_JOINED die Spalte EMAIL_ADDRESS mit der Spalte EMAIL_ADDRESS in der Tabelle CREDIT_SCORE , um sie zu verbinden.

  4. Klicken Sie auf Vorschau , um eine Vorschau der verknüpften Tabellen anzuzeigen.

  5. Schließen Sie das Vorschaufenster.

  6. Klicken Sie auf Weiter.

  7. Übernehmen Sie die Standardspaltennamen und klicken Sie auf Weiter.

  8. Geben Sie auf der Seite Zuweisen und überprüfen für Ansichtsname APPLICANTS_APPLICATIONS_CREDIT_SCORE_JOINEDein.

  9. Lassen Sie dieses Mal Zu Projekt zuordnen ausgewählt und wählen Sie dann das Projekt Datenintegration aus.

  10. Klicken Sie auf Ansicht erstellen.

  11. Klicken Sie nach Abschluss der Virtualisierung auf Zu virtualisierten Daten wechseln , um die neu erstellte Joinansicht anzuzeigen.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die Seite Virtualisierte Daten . Sie können jetzt mit den virtuellen Daten in Ihrem Projekt arbeiten.

Virtualisierte Daten




Aufgabe 6: API-Schlüssel generieren

Vorschau-Lernprogrammvideo Um eine Vorschau dieser Task anzuzeigen, sehen Sie sich das Video ab 08:27an.

Sie müssen Ihre persönlichen Berechtigungsnachweise in Form eines API-Schlüssels angeben, um virtualisierte Assets anzuzeigen. Wenn Sie noch keinen gespeicherten API-Schlüssel haben, führen Sie diese Schritte aus, um einen API-Schlüssel zu erstellen.

  1. Rufen Sie die Seite API-Schlüssel in der IBM Cloud -Konsole auf. Melden Sie sich an, wenn Sie dazu aufgefordert werden.

  2. Klicken Sie auf der Seite API-Schlüssel auf Erstellen Sie einen IBM Cloud -API-Schlüssel. Wenn Sie über vorhandene API-Schlüssel verfügen, kann die Schaltfläche Erstellenlauten.

  3. Geben Sie einen Namen und eine Beschreibung ein.

  4. Klicken Sie auf Erstellen.

  5. Kopieren Sie den API-Schlüssel.

  6. Laden Sie den API-Schlüssel für die zukünftige Verwendung herunter.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die Seite 'API-Schlüssel'. Sie können nun die virtuelle Tabelle im Projekt anzeigen.

Seite 'API-Schlüssel'




Aufgabe 7: Auf die Ansicht für virtuelle Joins im Projekt zugreifen

Vorschau-Lernprogrammvideo Um eine Vorschau dieser Task anzuzeigen, sehen Sie sich das Video ab 09:01an.

Die virtuelle Tabelle wurde Ihrem Projekt zusammen mit einer Verbindung zu Data Virtualizationhinzugefügt. Führen Sie die folgenden Schritte aus, um das Projekt zu öffnen und die virtuellen Daten und die Verbindungsinformationen anzuzeigen, die für den Zugriff auf die virtuellen Daten erforderlich sind.

  1. Wechseln Sie zurück zu Cloud Pak for Data. Wählen Sie im Navigationsmenü Navigationsmenü Projekte > Alle Projekte anzeigenaus.

  2. Öffnen Sie das Projekt Datenintegration .

  3. Klicken Sie auf die Registerkarte Assets.

  4. Öffnen Sie alle virtualisierten Daten. Klicken Sie beispielsweise auf das Datenasset, das mit Ihrem Schemanamen beginnt, gefolgt von APPLICANTS_APPLICATIONS_CREDIT_SCORE_VERKNÜPFT , um es anzuzeigen.

  5. Geben Sie Ihre Berechtigungsnachweise für den Zugriff auf das Datenasset an.

  6. Wählen Sie als Authentifizierungsmethode API-Schlüsselaus.

  7. Fügen Sie Ihren API-Schlüsselein.
    API-Schlüssel einfügen

  8. Klicken Sie auf Connect (Verbinden).

  9. Blättern Sie durch das Datenasset, um alle Bewerber aus dem Bundesstaat Kalifornien anzuzeigen.

Symbol für Prüfpunkt Fortschritt überprüfen

Die folgende Abbildung zeigt die virtuellen Daten im Projekt. Jetzt können Sie die virtuellen Daten analysieren.

Virtuelle Tabelle anzeigen



Als Datenentwickler der Golden Bank haben Sie Data Virtualization verwendet, um Daten aus verschiedenen Datenquellen und mit unterschiedlichen Typen zu kombinieren. Sie haben die SQL-Syntax verwendet und Daten ohne Versetzen von Daten aufgerufen und kombiniert.


Bereinigung (optional)

Wenn Sie die Lernprogramme im Anwendungsfall "Datenintegration" wiederholen möchten, löschen Sie die folgenden Artefakte.

Artefakt Vorgehensweise zum Löschen
Verbindungen im Platform assets catalog Asset aus einem Katalog entfernen
Virtualisierte Daten Navigieren Sie zu Daten > Data virtualization. Rufen Sie auf der Seite Virtualisierte Daten das Menü Überlauf Überlaufmenü für eine Tabelle auf und wählen Sie Entfernenaus.
Datenquellen Navigieren Sie zu Daten > Data virtualization. Klicken Sie auf der Seite Datenquellen auf Löschen Löschen für eine Verbindung.
Beispielprojekt für Datenintegration Projekt löschen

Nächste Schritte

Weitere Informationen

Übergeordnetes Thema: Lernprogramme für Anwendungsfälle

Generative KI-Suche und -Antwort
Diese Antworten werden von einem großen Sprachmodell in watsonx.ai basierend auf dem Inhalt der Produktdokumentation generiert. Weitere Informationen